Author Topic: AV Linux 6.0.3 ISO and HotfixUpdates released!  (Read 8787 times)

0 Members and 1 Guest are viewing this topic.

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 2475
  • Karma: +5/-0
  • A/V 'Nixer
    • www.bandshed.net
AV Linux 6.0.3 ISO and HotfixUpdates released!
« on: February 24, 2014, 10:31:37 PM »
Hi

A unscheduled surprise updated ISO for the AV Linux 6.0 series has been released addressing a few bugs on 6.0.2, some important software updates and moves to a newer updated 3.10.27-PAE lowlatency default kernel provided by Trulan Martin. Please note that an optional full preempt RT kernel with headers is also conveniently placed in the home folder for those who feel they may need it. For people using PCI Audio cards and FireWire devices the default lowlatency kernels provide very good performance since AV Linux provides rtirq out-of-the-box, however as USB-2 Audio devices supported by Linux have grown in popularity some of them seem to respond and perform better with a full preempt RT kernel so that is why this option has been provided, it is important to mention RT Kernels can also present challenges with proprietary video drivers and further to that please read on below to the present boondoggle that is custom Linux kernels and proprietary video drivers...

Highlights of this release are the newly released Ardour3 3.5.357 with critical bugfixes and fixed detection of linuxVST plugins, the latest new JACK1 0.124.1, demo LV2 version of linuxDSP's AF2-10 EQ, The latest EQ10/CS10/Gate-LV2, fixes to Carla Plugin host binary with SFZ support fixed, Steam has been added however will not be actively maintained and LibreOffice is now at 4.2. For more detailed info please consult the changelog below.

For existing users of either AV Linux 6.0.1b and AV Linux 6.0.2 a hotfixupdatepak with the core improvements contained in 6.0.3 has been prepared. AV Linux 6.0.1b users will need to first install the 6.0.1b-6.0.2 updatepak and then the 6.0.3 updates. The links are at the bottom of this post.





**Important info about AV Linux 6.0.3 Kernels and Proprietary Video Drivers**


* The new default 3.10.27 PAE lowlatency kernel will work with NVidia proprietary drivers, ATi drivers will only work if ATi has fixed their broken 32bit build of the latest Catalyst version. I have no ATi hardware to test and confirm so any brave ATi users PLEASE comment what the status is with this kernel.

* The optional 3.10.27 PAE RT Kernel has had mixed results with nVidia (Trulan has managed to get nVidia to build and I so far have not). NO testing with ATi has been done. I suggest using the RT Kernel with Xorg Video drivers if possible for sanity's sake

* Please remember 3rd party Proprietary Video drivers are provided the best of intentions with SGFXI for convenience but they are "3rd Party" and therefore many of the problems they present (ie known broken ATi drivers....c'mon really AMD, that's what you have to offer ?!!) are beyond my control.




Changelog from AV Linux 6.0.2-6.0.3:

Bugfixes:

- Set numlock to off by default to avoid keyboard havoc with Netbooks and Small Laptops with combined number/letter keys
- Fixed Ardour3 builds to properly detect linuxVST plugins since XFCE4 launchers do not utilize environment variables (thanks Paul Davis!)
- Fixed Carla Plugin Host to properly load SFZ files (thanks falkTX!)
- Fixed DispcalGUI to launch properly
- Removed Compiz button from Wbar to avoid running unwanted instances
- Added all relevant Broadcom Wireless Firmware, Driver and Source Packages to ease setup as much as possible.


Updates:

- Updated 3.10.27avl2-pae default Kernel (optional RT Build available in your home folder) Thanks Trulan Martin!
- Updated Inkscape to 0.48.4
- Updated liblilv to 0.18.0
- Updated libsuil to 0.8.0
- Updated lv2-dev to 1.8.0
- Updated sratom to 0.4.4
- Updated JALV to 1.4.4+ extUI patch
- Updated fabla-lv2 to 1.3
- Updated Qsampler to 0.2.3
- Updated Qtractor to 0.5.12+SVN with debugging and NSM Session fixes
- Updated Pipelight to 0.2.4.2
- Updated Wine-Compholio to 1.7.11
- Updated Qjackctl to 0.3.11
- Updated Ardour/VST3 to 3.5.357
- Updated JACK and jackutils scripts to 0.124.1
- Updated LMMS to 0.4.15
- Updated Vamp-Plugins-SDK to 2.5 (Required to build Ardour3 Cairo Canvas)
- Updated Qsynth to 0.3.8
- Updated Qmidinet to 0.1.3
- Updated Carla to 1.2.4
- Updated Polyphone to 1.2
- Updated EQ10 LV2 to 2.0beta5.1+GTK UI fix
- Updated MDA LV2's to 1.2.2
- Updated LibreOffice to 4.2
- Updated HPLIP to 3.14.1
- Updated Wine to 1.6.2+rt

New Additions

- Steam *NOTE not being maintained for AV Linux YMMV!
- Qmidictl 0.1.1
- linuxDSP AF-210 EQ LV2 Demo
- Grub Customizer 4.0.3
- Timemachine 0.3.3
- Gmidimonitor 3.6+GIT
- GTK RecordmyDesktop 0.3.8.1+jackfix
- Alternate Ardour launch scripts for special cases: (Netbook sized screens, Buggy Video Drivers) *Full info in release notes

Release Notes: http://www.bandshed.net/pdf/603-ReleaseNotes.pdf
Get 6.0.3 here: http://www.bandshed.net/AVLinux.html *torrents are up, Seeders needed! Thanks Allen!
HotfixUpdatePak for 6.0.1b - 6.0.2: http://www.bandshed.net/hotfixupdatepak/AVL-602-HotfixUpdatePak-20131227.zip
HotfixUpdatePak for 6.0.2 - 6.0.3: http://www.bandshed.net/hotfixupdatepak/AVL-603-HotfixUpdatePak-20140222.zip
« Last Edit: February 25, 2014, 03:14:59 PM by GMaq »
AV Linux, Proudly created with Remastersys: http://www.bandshed.net/AVLinux.html

Offline dednikko

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
  • Remastersys and AVLinux User
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #1 on: February 26, 2014, 06:09:22 PM »
Pardon my n00biness, but I don't see how to install or even locate the new kernel. It wan't in the .zip that I downloaded. I also looked in the ftp, to no result. Any idea what I'm missing?

*****Nevermind I just saw the kernel repo. Excuse me while I go and try to make some sense of my brain.

Offline StraightToTheBar

  • Full Member
  • ***
  • Posts: 24
  • Karma: +0/-0
    • DecemberMetal
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #2 on: February 27, 2014, 01:47:56 AM »
Hi,

thanks for all the hard work, many good bugfixes and additions! Respect \m/

Offline Prof Knaakenbroed

  • Hero Member
  • *****
  • Posts: 100
  • Karma: +0/-0
    • Prof Knaakenbroed - Music
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #3 on: February 27, 2014, 03:03:00 PM »
Glen, you must be MANIAC. So much high quality work for us musicians !

Do the days in Canada count 96 hours ? Have you people in your house you could identify as your family ? Do they remember you ?

Friends, we really MUST appreciate that work ! Follow my example using the magic of PayPal.

C'mon, let's speak that important word together.... let it be a donation session !

Glen, thank you again. No issues here after installing, system is running fine and fast as a fox. Time for doing music again.


yours Prof Knaakenbroed

Offline Piklik

  • Hero Member
  • *****
  • Posts: 141
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #4 on: March 01, 2014, 12:06:42 AM »
Hi,

Thanks Gmaq for the all hard work you did/do!

I'd installed avl603 but:

1/always have an issue with my fireface800. It seems to be working, qjackctl (green lighted) but if i launch mixbus (or other audio apps) it doesn't find jack then the three tabs configuration box!

2/ I installed ati drivers with "sgfxi" and amdcccle refuse to launch even in root console! I have two screens but the windows can't go left on the second screen, the mouse cursor can! The window's moving is not flawless but as i can't tweak it with "amdcccle control" then i'm not able to determine if it is possible to fix that. Finally it is the same as previously. I deinstalled ati drivers with your suggestion "sgfxi -! 32" but after reboot arandr don't launch (wanted to use dual screens)!

Offline varpa

  • Hero Member
  • *****
  • Posts: 415
  • Karma: +1/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #5 on: March 01, 2014, 11:22:23 AM »
You mention problems with your Fireface800.   Its not clear to me what checks you have done to see that it is working, but it is clear that the interface is not actually working since it does not show up in qjackctl's connection tabs if I understand you correctly.   I would check these things:

1.  Do devices /dev/fw1 and /dev/fw1 exist when the fireface is connected to your computer and turned on?
/dev/fw0 is your firewire interface (should always be present) and /dev/fw1 is the fireface.

2.  Does the command "ffado-test Discover" find the fireface?   If it does there will be a lot of output (to the terminal, including mention of the fireface800 and listing of number of channels it has.

3.  You say that qjackctl appears to start jack correctly.   I suggest looking at the Messages panel and check for messages that the firewire interface is really being started.   Does the fireface have any diagnostic LEDs that turn on when a connection is made and are these turning on?

The best help for debugging firewire problems is to join the ffado-user@lists.sourceforge.net email list and post your problems there (http://www.ffado.org/?q=contact).    The people on the list are quite responsive and helpful.



 

Offline rockhopper

  • Sr. Member
  • ****
  • Posts: 76
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #6 on: March 01, 2014, 04:53:30 PM »
2/ I installed ati drivers with "sgfxi" and amdcccle refuse to launch even in root console!

The current AMD Catalyst driver, 13-12, doesn't work on 32-bit Debian distros. With AVLinux 6.0.2 it was possible to install the last working driver, 13-4, but unfortunately that driver only works with Linux kernels up to version 3.8 and AVL 6.0.3 ships with a 3.10 kernel. So the situation with AMD drivers kinda sucks at the moment. Hopefully a new Catalyst release will come along soon...

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 2475
  • Karma: +5/-0
  • A/V 'Nixer
    • www.bandshed.net
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #7 on: March 02, 2014, 09:40:22 AM »
@Piklik

Hi, I'm afraid I have no answers for the fireface, best to talk to the FFADO guys as suggested

As far as the video problems a workaround is to install the previous default kernel (3.6.11.2) from Synaptic and then run SGFXI manually using method 2 (more info in the User Manual). Then you can install the previous working ATi drivers with:

Code: [Select]
sgfxi -o 13-4
AV Linux, Proudly created with Remastersys: http://www.bandshed.net/AVLinux.html

Offline mauriciocamara

  • Full Member
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #8 on: March 02, 2014, 08:33:21 PM »
Hi, GMaq,

First of all, *congratulations* for developing such an *incredible* work. I've been using AVLinux for some months and it's unbeatable for my audio productions. :-) And AVLinux is installed on *all* my machines. ;-)

However... maybe some kind of bug... sorry... but AVLinux 6.0.3 doesn't seem to find my notebook internal wifi device. Previous AVLinux versions worked fine. Therefore, I am using internet by sharing my mobile connection thru an USB port. Any suggestions?

GMaq, THANK YOU!! And keep up the *remarkable* work (please!) :-D :-D :-D

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 2475
  • Karma: +5/-0
  • A/V 'Nixer
    • www.bandshed.net
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #9 on: March 03, 2014, 08:44:21 AM »
Hi,

Can you copy and paste the output of 'lspci' in a terminal?
AV Linux, Proudly created with Remastersys: http://www.bandshed.net/AVLinux.html

Offline mauriciocamara

  • Full Member
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #10 on: March 03, 2014, 12:49:59 PM »
Sure! :) Here we go:

lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] Device 1510
00:01.0 VGA compatible controller: ATI Technologies Inc Device 9802
00:01.1 Audio device: ATI Technologies Inc Device 1314
00:04.0 PCI bridge: Advanced Micro Devices [AMD] Device 1512
00:05.0 PCI bridge: Advanced Micro Devices [AMD] Device 1513
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode] (rev 40)
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 42)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller (rev 40)
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
00:16.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:16.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

I've noticed that, on another notebook of mine, wifi internal adapter is working ok.

Thanks!

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 2475
  • Karma: +5/-0
  • A/V 'Nixer
    • www.bandshed.net
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #11 on: March 03, 2014, 04:27:25 PM »
Hi,

Quote
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

I think I've made a mistake (an honest one though)... Because people have problems with Broadcom drivers I pre-installed everything to do with them for AV Linux 6.0.3 in hopes that people would find it easier to get them up and running without having to look around the internet for drivers, however the 'broadcom-sta-common' package creates a blacklist file in /etc/modprobe.d that prevents some of the Broadcom Kernel modules from loading, which is probably the issue.

There are 2 possible modules for Broadcom '43XX' devices so in order to fix this you will need to first manually load each module one at a time and see which one will allow your WiFi to work, once we determine which one works we can comment them out in the blacklist so they load properly.

So to try manually loading the b43legacy module do this in a Root terminal:

Code: [Select]
modprobe b43legacy
If this is the correct module then the Network Manager should give you a message that WiFi networks are available, or you may need to manually check in the Network Manager if a wireless connection is now available. If nothing happens then that is most likely the wrong module and you will need to try the other b43 module again in a Root Terminal like this:

Code: [Select]
modprobe b43
Hopefully one or the other works, if so then you will need to open the black list file and put a '#' comment in front of the module that works. In a Root terminal open the /etc/modprobe.d/broadcom-sta-common.conf file with this command:

Code: [Select]
gedit /etc/modprobe.d/broadcom-sta-common.conf
This will open the '.conf' blacklist file for editing, so now place a comment in front of the working module, in the example below I have commented out 'blacklist b43' as an example:

Quote
# wl module from Broadcom conflicts with ssb
# We must blacklist the following modules:
blacklist b44
blacklist b43legacy
# blacklist b43
blacklist brcm80211
blacklist brcmsmac
blacklist ssb
install wl /sbin/modprobe --ignore-install wl $CMDLINE_OPTS

Then save the text file in gedit and on the next boot your WiFi should work. Please let me know if this works for you
AV Linux, Proudly created with Remastersys: http://www.bandshed.net/AVLinux.html

Offline mauriciocamara

  • Full Member
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #12 on: March 03, 2014, 06:33:53 PM »
Hmmm... these two drivers didn't work it out... Maybe some other drivers? :-)

My other notebook is on my daughter's room, and she is asleep now. As soon as I get the chance, I'll check the lspci results and post them here.

Offline mauriciocamara

  • Full Member
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #13 on: March 06, 2014, 06:30:21 AM »
Ok... back for more! :-)

On my other notebook (this one with wifi adapter working 100%) I've got this:

lspci
00:00.0 Host bridge: Intel Corporation Core Processor DMI (rev 11)
00:03.0 PCI bridge: Intel Corporation Core Processor PCI Express Root Port 1 (rev 11)
00:08.0 System peripheral: Intel Corporation Core Processor System Management Registers (rev 11)
00:08.1 System peripheral: Intel Corporation Core Processor Semaphore and Scratchpad Registers (rev 11)
00:08.2 System peripheral: Intel Corporation Core Processor System Control and Status Registers (rev 11)
00:08.3 System peripheral: Intel Corporation Core Processor Miscellaneous Registers (rev 11)
00:10.0 System peripheral: Intel Corporation Core Processor QPI Link (rev 11)
00:10.1 System peripheral: Intel Corporation Core Processor QPI Routing and Protocol Registers (rev 11)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
01:00.0 VGA compatible controller: ATI Technologies Inc Redwood [Radeon HD 5600 Series]
01:00.1 Audio device: ATI Technologies Inc Redwood HDMI Audio [Radeon HD 5600 Series]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-Core Registers (rev 04)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 04)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 04)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 04)
ff:03.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller (rev 04)
ff:03.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Target Address Decoder (rev 04)
ff:03.4 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Test Registers (rev 04)
ff:04.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Control Registers (rev 04)
ff:04.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Address Registers (rev 04)
ff:04.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Rank Registers (rev 04)
ff:04.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 0 Thermal Control Registers (rev 04)
ff:05.0 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Control Registers (rev 04)
ff:05.1 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Address Registers (rev 04)
ff:05.2 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Rank Registers (rev 04)
ff:05.3 Host bridge: Intel Corporation Core Processor Integrated Memory Controller Channel 1 Thermal Control Registers (rev 04)


Any ideas?

Thanks!!

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 2475
  • Karma: +5/-0
  • A/V 'Nixer
    • www.bandshed.net
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #14 on: March 06, 2014, 12:37:18 PM »
Hi,

Quote
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)

This is a completely different device (Intel) it works because it uses a completely different (Intel) driver in the kernel so it doesn't have anything to do with the Broadcom drivers which are troublesome on Linux at the best of times.

OK so you are certain that the laptop that doesn't have working WiFi (ie the one with the Broadcom WiFi adaptor) worked with previous versions of AV Linux? Which version did it work with? AVL 6.0.1b or AVL 6.0.2?

I need to know to determine the best course of action for you..

AV Linux, Proudly created with Remastersys: http://www.bandshed.net/AVLinux.html

Offline mauriciocamara

  • Full Member
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #15 on: March 06, 2014, 07:05:24 PM »
Hi, GMaq! Thanks for posting!

Yes, I am sure that the laptop that is not currently working with wifi has worked previously with previous AVLinux versions.

It worked ok with AVLinux 6.0.1b *and* AVLinux 6.0.2. I still have the live DVDs of these versions. Would you like me to boot with them and post the lspci results?

Best regards... and thank you for your time!

P.S.: This same notebook has Linux Mint Debian installed (based on Debian), with wifi working. I can also post lspci results, if it helps somehow. Thanks!

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 2475
  • Karma: +5/-0
  • A/V 'Nixer
    • www.bandshed.net
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #16 on: March 08, 2014, 10:00:34 AM »
Hi,

OK thanks, it isn't necessary to repost the lspci results because that is just a listing of the PCI hardware on the machine which won't change.

Can you try this?:

In Synaptic Package Manager install the kernel and headers from AV Linux 6.0.2, so these packages:

l
Quote
inux-image-3.6.11.2-avl1-pae
linux-headers-3.6.11.2-avl1-pae

Now also uninstall these 2 packages:

Quote
broadcom-sta-common
broadcom-sta-source

Then reboot, select the kernel you just installed from the GRUB list and see if your WiFi works, please let me know the results...
AV Linux, Proudly created with Remastersys: http://www.bandshed.net/AVLinux.html

Offline mauriciocamara

  • Full Member
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #17 on: March 10, 2014, 11:06:39 AM »
Hi, GMaq!

I followed the instructions but I was unable to solve this issue.

On my next free time, I will

1. Make a new, fresh install of AVLinux 6.0.3;
2. Follow the same instructions:
   2.1 In Synaptic Package Manager, install linux-image-3.6.11.2-avl1-pae;
   2.2 In Synaptic Package Manager, install linux-headers-3.6.11.2-avl1-pae;
   2.3 In Synaptic Package Manager, uninstall broadcom-sta-common;
   2.4 In Synaptic Package Manager, uninstall broadcom-sta-source.

GMaq, Thank you for developing such an *excellent* distro! AVLinux 6.0.2 is simply *faster than ever*. I've been recording my acoustic instruments without a single xrun, this is *awesome*! I just made my first track using entirely AVLinux. I have planned and wished this for months, and now that I was able to do it I definitely don't want to recede to Microsoft OS again.

My *best* best best regards, GMaq. Honestly!

P.S.: I didn't find Start-Up Manager under the 'System' menu. How do I install it?

Offline guitarjoe

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
  • Remastersys and AVLinux User
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #18 on: March 19, 2014, 08:10:02 PM »
GMaq
Like Mauriciocamara, I'm having the same issue with my Linksys wireless with the Broadcom chip.  I recompiled the kernel with the 6.0.2 headers, as you asked:

1. Make a new, fresh install of AVLinux 6.0.3;
2. Follow the same instructions:
   2.1 In Synaptic Package Manager, install linux-image-3.6.11.2-avl1-pae;
   2.2 In Synaptic Package Manager, install linux-headers-3.6.11.2-avl1-pae;
   2.3 In Synaptic Package Manager, uninstall broadcom-sta-common;
   2.4 In Synaptic Package Manager, uninstall broadcom-sta-source.

My install is very fresh (just did it this weekend... yes, I'm a noob to AVLinux).  However, no luck with the wireless. 

Thx!
GuitarJoe

P.S.  Overall, I'm super impressed with what you've been able to accomplish with AVLinux, and I'm still just scratching the surface.  Thanks for all your efforts, and I'm looking forward to learning more about what's in there!

Offline mauriciocamara

  • Full Member
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #19 on: March 20, 2014, 11:48:57 AM »
Quote
Overall, I'm super impressed with what you've been able to accomplish with AVLinux(...)

I will have to use the same words as GuitarJoe: I am so impressed - and so GLAD -  that I simply don't mind to use my cell phone as an usb tethering device.

THANKS, GMaq! *Excellent* distro!!! :-D :-D :-D

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 2475
  • Karma: +5/-0
  • A/V 'Nixer
    • www.bandshed.net
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #20 on: March 20, 2014, 04:00:14 PM »
Hi,

Firstly, thanks both for your kind words, although with no wireless working I don't feel they are deserved  :blush:

I am afraid I am a bit puzzled by this problem, when I suggested to downgrade the kernel to 3.6.11.2 and remove the broadcom-sta packages I assumed that this would return the AV Linux base essentially to what was there in AV Linux 6.0.2 which according to Mauricio did have broadcom wifi working OOTB in his case. It appears that this isn't the case.

I unfortunately have no broadcom wifi devices in any of the machines I have access to so I can't test this effectively. If one or both of you could download AV Linux 6.0.2 and determine if it works as-is then you could simply install the 6.0.2-6.0.3 updatehotfixpak onto AV Linux 6.0.2 and go on from there.

The 6.0.2 ISO is still available here: http://bandshed.net/iso/avlinux6.0.2-xfce410-i386-en.iso
                                                      http://bandshed.net/iso/avlinux6.0.2-xfce410-i386-en.iso.md5

6.0.2-6.0.3 Update available here: http://www.bandshed.net/hotfixupdatepak/AVL-603-HotfixUpdatePak-20140222.zip

That is the best suggestion I have for the time being...
« Last Edit: March 20, 2014, 04:11:49 PM by GMaq »
AV Linux, Proudly created with Remastersys: http://www.bandshed.net/AVLinux.html

Offline guitarjoe

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
  • Remastersys and AVLinux User
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #21 on: March 21, 2014, 10:37:33 AM »
GMaq
Unfortunately I'm out of town all this weekend.  If Mauricio hasn't tried your recent suggestion first, I'll be able to get to it next week.  Meanwhile, I've got one long-honking cat5 cable running to the machine!  That works great!  Perhaps Mauricio can get to it sooner...
Thx!
GuitarJoe

Offline mauriciocamara

  • Full Member
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #22 on: March 22, 2014, 10:56:31 AM »
Hi, GMaq, Hi GuitarJoe!

I'll go home today - I'm an airliner copilot - and I will try that. Fortunately, I still got some previous AVLinux ISOs on my external HD.

After installing and applying the UpdateHotFixPack, I will post the results here.

GMaq, for AVLinux I would be happy to be a tester for my broadcom wifi device, or anything else. :-) :-) :-)

My best regards! And keep up the *excellent* work!

Offline mauriciocamara

  • Full Member
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #23 on: March 23, 2014, 09:25:38 AM »
Hi GMaq, Hi GuitarJoe!

Direct news from AVL 6.0.2 Live DVD: Wifi working ok! :-)

After installing the system and applying the UpdateHotFixPak, I will post the results.

Best regards!

Offline mauriciocamara

  • Full Member
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #24 on: March 23, 2014, 10:56:51 AM »
Hi GMaq, hi GuitarJoe!

AVLinux 6.0.2 installed and UpdateHotFixPak installed: wifi works ok! Thanks GMaq!

(BTW, thanks also to TotalChaos, since he also suggested me to try reinstalling AVL6.0.2 + UpdateHotFixPak)

I also have Start-Up Manager back! It's very useful to me, since I've got also LinuxMintDebianEdition and TangoStudioDebianWay (and Microsoft's OS) installed. Thaaaaaaanks!!!

Please let me know if I can provide you any further info.
Hey GuitarJoe, did this workaround also solved your wifi issue?

Best regards!

Offline guitarjoe

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
  • Remastersys and AVLinux User
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #25 on: March 23, 2014, 05:41:06 PM »
GMaq Mauricio

Glad to hear that worked for you.  Unfortunately, it did not for me.  LiveDVD didn't recognize it, so I went ahead and fully installed, but still no luck. 

I was reading on http://wireless.kernel.org/en/users/Drivers/b43 that there is a firmware fix that I need to apply to get the card to work correctly under Linux.  I'm still checking on that to see if doing that will mess the card up when I'm working under Windows.  Not sure yet.

Mauricio, did you previously do any of this firmware patching?  Do you use your card in both Linux and Windows? 

Thx!
Joe

Offline mauriciocamara

  • Full Member
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #26 on: March 23, 2014, 11:24:52 PM »
Hi Joe,

No, I did not performed any firmware patching. On AVL 6.0.2, wifi just worked out of the box... At bandshed, there is also AVL 6.0.1b available (LXDE version), and you can get it here:

http://bandshed.net/iso/

Would you like to try it? If this one works, you would need to apply the 2 UpdateHotFixPaks to update the system.

My wifi card is an internal one on my notebook; it works under Linux and Windows too. I've got a cheap USB wifi card at DealExtreme, but I never tried it here.

I don't think that a linux patch could ruin the device on Windows - well, I would be surprised if that happens.

Please let me know if I can help you anyway. :-) Good luck!

Offline guitarjoe

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
  • Remastersys and AVLinux User
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #27 on: March 26, 2014, 12:40:38 PM »
Guys

Thanks, but I've spent too much time on this issue as it is.  I'm going to buy an Intel-based WiFi card/usb and use that when I'm in AV Linux.  Just easier until I can move my PC back to a location where I can plug a wire in again.

Thx!
Joe

Offline guitarjoe

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
  • Remastersys and AVLinux User
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #28 on: March 26, 2014, 06:27:06 PM »
GMaq and Mauricio

I stopped at BestBuy after work and picked up a cheap USB Network Adapter (Belkin N150) for $15.  Plugged it in, punched in the passwords for my network, rebooted, and voila, wireless connectivity! 

The only weird thing is now my mouse pointer has turned to a black X.  I searched the forum, but didn't see anything on that.  Going to Google now and see if I can find anything.  Have you experienced this before?

Thx!
GuitarJoe

Offline mauriciocamara

  • Full Member
  • ***
  • Posts: 28
  • Karma: +0/-0
Re: AV Linux 6.0.3 ISO and HotfixUpdates released!
« Reply #29 on: March 26, 2014, 07:51:04 PM »
Hi, GuitarJoe!

These things should not be related to each other, IMHO...

What happens if you turn on your computer *without* the USB Network Adapter? Does the black X appears already?
If it doesn't... what happens if you complete your login (username + password) and plug your adapter?

Best regards!