Author Topic: Openshot > segmentation fault [SOLVED]  (Read 2087 times)

0 Members and 1 Guest are viewing this topic.

Offline touchstyle

  • Full Member
  • ***
  • Posts: 24
  • Karma: +0/-0
    • www.touchstyle.it
Openshot > segmentation fault [SOLVED]
« on: September 30, 2011, 04:33:27 PM »
Hi!
I tried to start Openshot but:

Code: [Select]
******@******:~$ openshot_launch.sh
Added /opt/openshot/openshot to system path
--------------------------------
   OpenShot (version 1.3.1)
--------------------------------
Process no longer exists: 4058.  Creating new pid lock file.
There were some errors calling melt using os.Popen()
There were some errors calling melt using os.Popen()
There were some errors calling melt using os.Popen()
/usr/bin/openshot_launch.sh: line 2:  5977 Segmentation fault      PYTHONPATH=$PYTHONPATH:/usr/lib/python2.6/site-packages/ /opt/openshot/bin/openshot

I'm working with 3.0.3-avl-3 kernel.

Any idea?

Thanks,
Touch.


« Last Edit: October 11, 2011, 03:20:33 AM by touchstyle »
_______________________________________
Denis AKA Touchstyle
www.touchstyle.it

Offline trulan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 910
  • Karma: +1/-0
Re: Openshot > segmentation fault
« Reply #1 on: September 30, 2011, 08:32:22 PM »
Have you by any chance upgraded Openshot or the mlt packages?  Openshot 1.4 requires the mlt 0.7.5 packages, and if you have upgraded mlt you will need Openshot 1.4.
http://www.bandshed.net/custom/openshot_1.4.0BZRavlinux-1_i386.deb
http://www.bandshed.net/custom/mlt_0.7.5GITavlinux-1_i386.deb
http://www.bandshed.net/custom/python-mlt_0.7.5GITavlinux-1_i386.deb

Offline touchstyle

  • Full Member
  • ***
  • Posts: 24
  • Karma: +0/-0
    • www.touchstyle.it
Re: Openshot > segmentation fault
« Reply #2 on: October 02, 2011, 03:47:36 PM »
No way.
Melt version "MLT melt 0.7.5"

Code: [Select]
touchstyle@******:~$ openshot_launch.sh
Added /opt/openshot/openshot to system path
--------------------------------
   OpenShot (version 1.4.0)
--------------------------------
Process no longer exists: 3385.  Creating new pid lock file.
Default profile does not exist: DV NTSC. Changing default profile to DV/DVD NTSC.

Detecting formats, codecs, and filters...
---
video_codecs:
  - a64multi
  - a64multi5
  - asv1
  - asv2
  - bmp
  - dnxhd
  - dvvideo
  - ffv1
  - ffvhuff
  - flashsv
  - flv
  - gif
  - h261
  - h263
  - h263p
  - huffyuv
  - jpegls
  - ljpeg
  - mjpeg
  - mpeg1video
  - mpeg2video
  - mpeg4
  - msmpeg4v1
  - msmpeg4v2
  - msmpeg4
  - pam
  - pbm
  - pcx
  - pgm
  - pgmyuv
  - png
  - ppm
  - qtrle
  - rawvideo
  - roqvideo
  - rv10
  - rv20
  - sgi
  - snow
  - svq1
  - targa
  - tiff
  - v210
  - wmv1
  - wmv2
  - zlib
  - zmbv
  - libdirac
  - libtheora
  - libvpx
  - libx264
  - libxvid
...
---
audio_codecs:
  - aac
  - ac3
  - alac
  - flac
  - mp2
  - nellymoser
  - real_144
  - sonic
  - sonicls
  - vorbis
  - wmav1
  - wmav2
  - pcm_alaw
  - pcm_f32be
  - pcm_f32le
  - pcm_f64be
  - pcm_f64le
  - pcm_mulaw
  - pcm_s8
  - pcm_s16be
  - pcm_s16le
  - pcm_s24be
  - pcm_s24daud
  - pcm_s24le
  - pcm_s32be
  - pcm_s32le
  - pcm_u8
  - pcm_u16be
  - pcm_u16le
  - pcm_u24be
  - pcm_u24le
  - pcm_u32be
  - pcm_u32le
  - pcm_zork
  - roq_dpcm
  - adpcm_adx
  - g722
  - g726
  - adpcm_ima_qt
  - adpcm_ima_wav
  - adpcm_ms
  - adpcm_swf
  - adpcm_yamaha
  - libfaac
  - libgsm
  - libgsm_ms
  - libmp3lame
  - libopencore_amrnb
  - libvorbis
...
---
formats:
  - a64
  - ac3
  - adts
  - aiff
  - amr
  - asf
  - ass
  - asf_stream
  - au
  - avi
  - avm2
  - cavsvideo
  - crc
  - daud
  - dirac
  - dnxhd
  - dts
  - dv
  - eac3
  - ffm
  - filmstrip
  - flac
  - flv
  - framecrc
  - framemd5
  - g722
  - gif
  - gxf
  - h261
  - h263
  - h264
  - image2
  - image2pipe
  - ipod
  - m4v
  - md5
  - matroska
  - matroska
  - mjpeg
  - mlp
  - mmf
  - mov
  - mp2
  - mp3
  - mp4
  - mpeg
  - vcd
  - mpeg1video
  - dvd
  - svcd
  - mpeg2video
  - vob
  - mpegts
  - mpjpeg
  - mxf
  - mxf_d10
  - null
  - nut
  - ogg
  - alaw
  - mulaw
  - f64be
  - f64le
  - f32be
  - f32le
  - s32be
  - s32le
  - s24be
  - s24le
  - s16be
  - s16le
  - s8
  - u32be
  - u32le
  - u24be
  - u24le
  - u16be
  - u16le
  - u8
  - psp
  - rawvideo
  - rm
  - RoQ
  - rso
  - rtp
  - rtsp
  - sap
  - sox
  - spdif
  - srt
  - swf
  - 3g2
  - 3gp
  - truehd
  - rcv
  - voc
  - wav
  - webm
  - yuv4mpegpipe
  - alsa
  - oss
...
/usr/bin/openshot_launch.sh: line 2:  3400 Segmentation fault      PYTHONPATH=$PYTHONPATH:/usr/lib/python2.6/site-packages/ /opt/openshot/bin/openshot

 :blush:

Others?

Thanks,
Touch.
_______________________________________
Denis AKA Touchstyle
www.touchstyle.it

Offline trulan

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 910
  • Karma: +1/-0
Re: Openshot > segmentation fault
« Reply #3 on: October 02, 2011, 03:55:22 PM »
Did you also upgrade the python-mlt package?  If you did, I'm not sure what to say, I can't reproduce the problem here...

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 2478
  • Karma: +5/-0
  • A/V 'Nixer
    • www.bandshed.net
Re: Openshot > segmentation fault
« Reply #4 on: October 02, 2011, 06:00:23 PM »
Hi,

This may be the issue: https://bugs.launchpad.net/openshot/+bug/862490

touchstyle are you using a non-English locale? If so I'll probably have to build an updated package since they have fixed this in 1.4.1 development.
AV Linux, Proudly created with Remastersys: http://www.bandshed.net/AVLinux.html

Offline GMaq

  • Administrator
  • Hero Member
  • *****
  • Posts: 2478
  • Karma: +5/-0
  • A/V 'Nixer
    • www.bandshed.net
AV Linux, Proudly created with Remastersys: http://www.bandshed.net/AVLinux.html

Offline touchstyle

  • Full Member
  • ***
  • Posts: 24
  • Karma: +0/-0
    • www.touchstyle.it
Re: Openshot > segmentation fault
« Reply #6 on: October 11, 2011, 03:20:09 AM »
_______________________________________
Denis AKA Touchstyle
www.touchstyle.it